import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(1[2-9]|[2-9][0-9]|[1-9][0-9][0-9]+)$";
final String string = "1\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "5\n"
+ "6\n"
+ "7\n"
+ "8\n"
+ "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "13\n"
+ "14\n"
+ "15\n"
+ "16\n"
+ "20\n"
+ "21\n"
+ "30\n"
+ "99\n"
+ "100\n"
+ "101\n"
+ "299\n"
+ "5411\n"
+ "100000\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}