$re = '/^(1[2-9]|[2-9][0-9]|[1-9][0-9][0-9]+)$/m';
$str = '1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
20
21
30
99
100
101
299
5411
100000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);