import re
regex = re.compile(r"^(1[2-9]|[2-9][0-9]|[1-9][0-9][0-9]+)$", flags=re.MULTILINE)
test_str = ("1\n"
"2\n"
"3\n"
"4\n"
"5\n"
"6\n"
"7\n"
"8\n"
"9\n"
"10\n"
"11\n"
"12\n"
"13\n"
"14\n"
"15\n"
"16\n"
"20\n"
"21\n"
"30\n"
"99\n"
"100\n"
"101\n"
"299\n"
"5411\n"
"100000\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")