#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+\/[-+.\w]+"
Local $sString = "application/atom+xml" & @CRLF & _
"application/EDI-X12" & @CRLF & _
"application/xml-dtd" & @CRLF & _
"application/zip" & @CRLF & _
"application/vnd.openxmlformats-officedocument.presentationml.presentation" & @CRLF & _
"video/quicktime"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")