re = /\w+\/[-+.\w]+/
str = 'application/atom+xml
application/EDI-X12
application/xml-dtd
application/zip
application/vnd.openxmlformats-officedocument.presentationml.presentation
video/quicktime'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end