import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\/[-+.\\w]+";
final String string = "application/atom+xml\n"
+ "application/EDI-X12\n"
+ "application/xml-dtd\n"
+ "application/zip\n"
+ "application/vnd.openxmlformats-officedocument.presentationml.presentation\n"
+ "video/quicktime";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}