package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+\/[-+.\w]+`)
var str = `application/atom+xml
application/EDI-X12
application/xml-dtd
application/zip
application/vnd.openxmlformats-officedocument.presentationml.presentation
video/quicktime`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}