#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:ht|f)tps?:\/\/\w+\.\w{2}+[\/\w-.]+"
Local $sString = "http://matthiasweiss.at/asd/asd" & @CRLF & _
"" & @CRLF & _
"ftp://hallo.welt" & @CRLF & _
"" & @CRLF & _
"https://hallowelt.jpg" & @CRLF & _
"" & @CRLF & _
"http://asdasd.aa/jojoji.jiji" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")