import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:ht|f)tps?:\\/\\/\\w+\\.\\w{2}+[\\/\\w-.]+";
final String string = "http://matthiasweiss.at/asd/asd\n\n"
+ "ftp://hallo.welt\n\n"
+ "https://hallowelt.jpg\n\n"
+ "http://asdasd.aa/jojoji.jiji\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}