// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?:ht|f)tps?:\/\/\w+\.\w{2}+[\/\w-.]+").unwrap();
let string = "http://matthiasweiss.at/asd/asd
ftp://hallo.welt
https://hallowelt.jpg
http://asdasd.aa/jojoji.jiji
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}