package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{3})(\d{3})(\d{4})`)
var str = []byte(`1234567890`)
var substitution = []byte("($1)-$2-$3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}