use strict;
my $str = '1234567890';
my $regex = qr/(\d{3})(\d{3})(\d{4})/p;
my $subst = '($1)-$2-$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";