const regex = /(\d{3})(\d{3})(\d{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3})(\\d{3})(\\d{4})', '')
const str = `1234567890`;
const subst = `($1)-$2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);