import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/mywebsite\\.com\\/([a-zA-Z]+)$";
final String string = "http://mywebsite.com/1234\n"
+ "http://mywebsite.com/foo\n"
+ "http://mywebsite.com/bar\n"
+ "http://google.com\n"
+ "http://mywebsite.com/bar6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}