const regex = /http:\/\/mywebsite\.com\/([a-zA-Z]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/mywebsite\\.com\\\/([a-zA-Z]+)$', 'gm')
const str = `http://mywebsite.com/1234
http://mywebsite.com/foo
http://mywebsite.com/bar
http://google.com
http://mywebsite.com/bar6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}