re = /http:\/\/mywebsite\.com\/([a-zA-Z]+)$/m
str = 'http://mywebsite.com/1234
http://mywebsite.com/foo
http://mywebsite.com/bar
http://google.com
http://mywebsite.com/bar6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end