using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\[\[.*?]]).*";
string substitution = @"# \1";
string input = @"/* Clarification 0001: [[Specific Clarification]] */";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}