$re = '/.*(\[\[.*?]]).*/m';
$str = '/* Clarification 0001: [[Specific Clarification]] */';
$subst = "# \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;