re = /.*(\[\[.*?]]).*/m
str = '/* Clarification 0001: [[Specific Clarification]] */'
subst = '# \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result