use strict;
my $str = '/* Clarification 0001: [[Specific Clarification]] */';
my $regex = qr/.*(\[\[.*?]]).*/mp;
my $subst = '# \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";