const regex = /(?|(?:@can|hasPermissionTo|hasDirectPermission)\(\s*(?P<quote>['"])(?P<string>.*?)\1\)|\((?P<quote>['"])can:(?P<string>.*?)\1\)|\(\[[^][]*(?P<quote>['"])can:(?P<string>.*?)\1[^][]*]\))/sgu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|(?:@can|hasPermissionTo|hasDirectPermission)\\(\\s*(?P<quote>[\'"])(?P<string>.*?)\\1\\)|\\((?P<quote>[\'"])can:(?P<string>.*?)\\1\\)|\\(\\[[^][]*(?P<quote>[\'"])can:(?P<string>.*?)\\1[^][]*]\\))', 'sgu')
const str = `@can('event-tools::menu.view')
\$this->middleware('can:access registration check');
Route::prefix('administration')->middleware(['auth', 'verified', 'can:access admin area'])->group(static function () {
Route::prefix('organisation/{organisation}')->middleware(['auth', 'verified', 'can:access organisation area', 'mustHaveOrganisation'])->group(static function () {`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}