$re = '/(?|(?:@can|hasPermissionTo|hasDirectPermission)\(\s*(?P<quote>[\'"])(?P<string>.*?)\1\)|\((?P<quote>[\'"])can:(?P<string>.*?)\1\)|\(\[[^][]*(?P<quote>[\'"])can:(?P<string>.*?)\1[^][]*]\))/su';
$str = '@can(\'event-tools::menu.view\')
$this->middleware(\'can:access registration check\');
Route::prefix(\'administration\')->middleware([\'auth\', \'verified\', \'can:access admin area\'])->group(static function () {
Route::prefix(\'organisation/{organisation}\')->middleware([\'auth\', \'verified\', \'can:access organisation area\', \'mustHaveOrganisation\'])->group(static function () {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);