package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]{3})-?([0-9]{3})-?([0-9]{3})-?(?<LAST>[0-9]{3})?(?(<LAST>)<LAST>)$`)
var str = `009026405
01009556500
226-356-839
00829029200
008-018-454
009-513-213
00383951900
000147765000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}