// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9]{3})-?([0-9]{3})-?([0-9]{3})-?(?<LAST>[0-9]{3})?(?(<LAST>)<LAST>)$").unwrap();
let string = "009026405
01009556500
226-356-839
00829029200
008-018-454
009-513-213
00383951900
000147765000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}