re = /^([0-9]{3})-?([0-9]{3})-?([0-9]{3})-?(?<LAST>[0-9]{3})?(?(<LAST>)<LAST>)$/m
str = '009026405
01009556500
226-356-839
00829029200
008-018-454
009-513-213
00383951900
000147765000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end