$re = '/^([0-9]{3})-?([0-9]{3})-?([0-9]{3})-?(?<LAST>[0-9]{3})?(?(<LAST>)<LAST>)$/m';
$str = '009026405
01009556500
226-356-839
00829029200
008-018-454
009-513-213
00383951900
000147765000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);