#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(works|texts)(\/.+?)(\/.+?)?\/"
Local $sString = "http://127.0.0.1/ocko/works/videos/" & @CRLF & _
"" & @CRLF & _
"http://127.0.0.1/ocko/texts/shit/" & @CRLF & _
"" & @CRLF & _
"http://127.0.0.1/ocko/works/teletubbies/oint/" & @CRLF & _
"" & @CRLF & _
"http://127.0.0.1/ocko/works/teletubbies/oint/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")