re = /(works|texts)(\/.+?)(\/.+?)?\//
str = 'http://127.0.0.1/ocko/works/videos/
http://127.0.0.1/ocko/texts/shit/
http://127.0.0.1/ocko/works/teletubbies/oint/
http://127.0.0.1/ocko/works/teletubbies/oint/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end