package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(works|texts)(\/.+?)(\/.+?)?\/`)
var str = `http://127.0.0.1/ocko/works/videos/
http://127.0.0.1/ocko/texts/shit/
http://127.0.0.1/ocko/works/teletubbies/oint/
http://127.0.0.1/ocko/works/teletubbies/oint/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}