using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(works|texts)(\/.+?)(\/.+?)?\/";
string input = @"http://127.0.0.1/ocko/works/videos/
http://127.0.0.1/ocko/texts/shit/
http://127.0.0.1/ocko/works/teletubbies/oint/
http://127.0.0.1/ocko/works/teletubbies/oint/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}