using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?![^{]+})(?:\.|#)([_a-zA-Z]+[_a-zA-Z0-9-]*)";
string input = @"#test{}
#test[type=button]{}
.test{}
.test.test2{}
#too-many-test{}
.is_URL-will-be_a{background: url(http://a.part.of.a.class.name.jpg) }
#so > .that.s .it thank .you{}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}