re = /(?![^{]+})(?:\.|#)([_a-zA-Z]+[_a-zA-Z0-9-]*)/
str = '#test{}
#test[type=button]{}
.test{}
.test.test2{}
#too-many-test{}
.is_URL-will-be_a{background: url(http://a.part.of.a.class.name.jpg) }
#so > .that.s .it thank .you{}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end