import Foundation
let pattern = ##"(?![^{]+})(?:\.|#)([_a-zA-Z]+[_a-zA-Z0-9-]*)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#test{}
#test[type=button]{}
.test{}
.test.test2{}
#too-many-test{}
.is_URL-will-be_a{background: url(http://a.part.of.a.class.name.jpg) }
#so > .that.s .it thank .you{}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)