$re = '/(?![^{]+})(?:\.|#)([_a-zA-Z]+[_a-zA-Z0-9-]*)/';
$str = '#test{}
#test[type=button]{}
.test{}
.test.test2{}
#too-many-test{}
.is_URL-will-be_a{background: url(http://a.part.of.a.class.name.jpg) }
#so > .that.s .it thank .you{}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);