const regex = /(?<= )(?=[_{])|(?<=[_}])(?=\W)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<= )(?=[_{])|(?<=[_}])(?=\\W)', 'gm')
const str = `Here is my very _special string_ with {different}, types of _delimiters_--that might _101_ even {repeat a few times}.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}