re = /(?<= )(?=[_{])|(?<=[_}])(?=\W)/m
str = 'Here is my very _special string_ with {different}, types of _delimiters_--that might _101_ even {repeat a few times}.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end