use strict;
my $str = 'Here is my very _special string_ with {different}, types of _delimiters_--that might _101_ even {repeat a few times}.
';
my $regex = qr/(?<= )(?=[_{])|(?<=[_}])(?=\W)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}