using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"97890(\d)00(?!\1)(\d)(?!\2|\1)\d";
string input = @"9789010023
9789020012
9789030045
9789030044";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}