re = /97890(\d)00(?!\1)(\d)(?!\2|\1)\d/m
str = '9789010023
9789020012
9789030045
9789030044'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end