const regex = /97890(\d)00(?!\1)(\d)(?!\2|\1)\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('97890(\\d)00(?!\\1)(\\d)(?!\\2|\\1)\\d', 'gm')
const str = `9789010023
9789020012
9789030045
9789030044`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}