$re = '/97890(\d)00(?!\1)(\d)(?!\2|\1)\d/m';
$str = '9789010023
9789020012
9789030045
9789030044';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);