using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+-re-.+?-(.+)-\d+.+";
string input = @"re-medbedb-re-darksun-re-bit8k-khorosho-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
re-medbedb-re-darksun-re-bit8k-dsdsdsd-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}