const regex = /^.+-re-.+?-(.+)-\d+.+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+-re-.+?-(.+)-\\d+.+', 'gm')
const str = `re-medbedb-re-darksun-re-bit8k-khorosho-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
re-medbedb-re-darksun-re-bit8k-dsdsdsd-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}