re = /^.+-re-.+?-(.+)-\d+.+/m
str = 're-medbedb-re-darksun-re-bit8k-khorosho-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
re-medbedb-re-darksun-re-bit8k-dsdsdsd-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end