import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)\".*?(?<!\\\\)\"";
final String string = " shete we go \"\\\"yeah\" something rl\n"
+ "semy something \"dugs\" hdis \"and \\\"this\\\" os cool\"\n\n\n"
+ "\"\"\n\n\n\n"
+ "\"\\fdfdf\"\n"
+ "\"word\\\"\n"
+ "\"\\word\"\n"
+ "\"\\word\\\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}