$re = '/(?<!\\\\)".*?(?<!\\\\)"/m';
$str = ' shete we go "\\"yeah" something rl
semy something "dugs" hdis "and \\"this\\" os cool"
""
"\\fdfdf"
"word\\"
"\\word"
"\\word\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);