import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www.)?(facebook\\.com)\\/(\\S*\\/)*(videos?\\/(embed\\?video_id=|vb.\\d+\\/)?)(\\d+)";
final String string = "https://www.facebook.com/video/embed?video_id=368508506585276\n"
+ "https://www.facebook.com/1399785403664362/videos/1428693740773528/\n"
+ "https://www.facebook.com/snackk100/videos/754790044667598/?permPage=1\n"
+ "https://www.facebook.com/insight.co.kr/videos/vb.374726359324617/907652546031993/?type=2&theater\n"
+ "https://www.facebook.com/Jrockradio/videos/vb.102198813200663/880536688700201/?type=2&theater";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}