// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(https?:\/\/)?(www.)?(facebook\.com)\/(\S*\/)*(videos?\/(embed\?video_id=|vb.\d+\/)?)(\d+)").unwrap();
let string = "https://www.facebook.com/video/embed?video_id=368508506585276
https://www.facebook.com/1399785403664362/videos/1428693740773528/
https://www.facebook.com/snackk100/videos/754790044667598/?permPage=1
https://www.facebook.com/insight.co.kr/videos/vb.374726359324617/907652546031993/?type=2&theater
https://www.facebook.com/Jrockradio/videos/vb.102198813200663/880536688700201/?type=2&theater";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}