const regex = /(https?:\/\/)?(www.)?(facebook\.com)\/(\S*\/)*(videos?\/(embed\?video_id=|vb.\d+\/)?)(\d+)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/)?(www.)?(facebook\\.com)\\\/(\\S*\\\/)*(videos?\\\/(embed\\?video_id=|vb.\\d+\\\/)?)(\\d+)', 'gim')
const str = `https://www.facebook.com/video/embed?video_id=368508506585276
https://www.facebook.com/1399785403664362/videos/1428693740773528/
https://www.facebook.com/snackk100/videos/754790044667598/?permPage=1
https://www.facebook.com/insight.co.kr/videos/vb.374726359324617/907652546031993/?type=2&theater
https://www.facebook.com/Jrockradio/videos/vb.102198813200663/880536688700201/?type=2&theater`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}