$re = '/(https?:\/\/)?(www.)?(facebook\.com)\/(\S*\/)*(videos?\/(embed\?video_id=|vb.\d+\/)?)(\d+)/im';
$str = 'https://www.facebook.com/video/embed?video_id=368508506585276
https://www.facebook.com/1399785403664362/videos/1428693740773528/
https://www.facebook.com/snackk100/videos/754790044667598/?permPage=1
https://www.facebook.com/insight.co.kr/videos/vb.374726359324617/907652546031993/?type=2&theater
https://www.facebook.com/Jrockradio/videos/vb.102198813200663/880536688700201/?type=2&theater';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);